Перейти к содержанию

Решение проблемы с Coges (неправильная работа выдачи, сброс монет при включении)


Рекомендуемые сообщения

оказыватеся с этой проблемой многие сталкиваются. (сам не захожу на форму, а в группе телеги попросили сюда написать)

 

теперь расскажу про симптомы их причину и как ее устранить.

 

1. при включении монетник может выдать какой одну или несколько монет.

2. при выдачи сдачи, рычаг выдачи может сделать пол роборота или несколько оборотов.

 

все это связано с неправильной работой механизма определения положения, который реализован при помощи магнита и датчика холла.

как это работает

на шестеренке стоит магнит. плата с датчиком стоит на удалении сантиметра. для "шлюза" магнитного поля используется металический штырь.

в определенном положении шестерни, магнит находится одной линии со "штырем" и датчик холла србатывает.

при включении, монетник инитит выдачу ( что бы рычаги стояли в нужной позиции)

если датчик помер, то мотор будет крутить какое то время, а потом остановиться и пометит эту тубу как не рабучую (моргает на экранеи не не выдает этот номинал)

в дуругих случаях проблема с магнитом (которая может возникнуть только спустя время)

нужно разобрать механизм выдачи. и постомтреть на магниты. в нормальном состоянии они блестят (обычный хромированый неодим).

а если на магните как бы металическая пыль, то проблема найдена :)))) (на "шпыньке" у этого магнита, будут видны механические повреждения)

магнит немного "выпирает" из своего посадочного места, и контактирует с "шпыньком". со временем он разрушается и мы полчаем тот самый "плавающий" дефект.

меняем магнит ( там стоит цилиндрический 3х2 в розничу их продают по 2рубля.) и проблема уходит.

при уставке магнита надо что бы он стоял плотно ( проходя мимо "шпынька" магнитное поле может его сместить) и самое главное что бы он не выпирал. если его "утопить" сильно то тоже ничего хорошего не будет.

все оказалось просто. при устаноке магнита он был немного выше, и с каждым оборотом контактировал с железкой, и потихоньку разрушался. потом поле стало слабым и получаем проблемы.

объяснение 1 причины.

при включении идет инициализация выдачи. и если магнит напротив датчика, то мотор не крутит, а если нет, то крутит до срабатывания датчика. при частично разрашенном магните, поле слабее. и мотор на выдаче остановиться не в момент нахождения, а в момент когда поле уйдет. эмитировать это просто. достаточно несного сдвинуть рычаг и включить.

проблема 2

опять же магнит не дает поле. и мотор будет крутить какое то время а потом по таймауту отключится. я видет как выдал 3 монеты вместо одной. таже тактильно чувствуется что магнит держит хуже чем другие.

 

Изменено пользователем AlexTransit
дополнил.
  • Нравится 1
  • Спасибо 2
Ссылка на сообщение
Поделиться на другие сайты
  • 3 недели спустя...
  • Ответов 1
  • Дата создания
  • Последний ответ

Лучшие авторы в теме

Популярные дни

Лучшие авторы в теме

Популярные посты

оказыватеся с этой проблемой многие сталкиваются. (сам не захожу на форму, а в группе телеги попросили сюда написать)   теперь расскажу про симптомы их причину и как ее устранить.  

Дополнение.

на одной "глючащей трубе" магнит был без повреждений, но магнитное поле было слабее чем на других трубах. ( специального инструмента для измерения поля нет. так что смотрел какой вес держит)

магнит заменил. купюрник поставил на точку (где большая нагрузка по выдаче.) вроде проблема ушла.

 

PS штатный магнит диаметром 3х2. можно поставить магнит 3х3, а можно дополнительно примагнитить "снизу" 3х1.

 

Ссылка на сообщение
Поделиться на другие сайты
  • Наши партнеры




×
×
  • Создать...

Важная информация

Используя этот сайт, Вы соглашаетесь с Условия использования.

Яндекс.Метрика